Introduction

Created with the Personal Edition of HelpNDoc: Free iPhone documentation generator

Copyright © 2015 by Pierre de Ponthiere. All Rights Reserved.


Overview

Introduction ››

Overview

Top Next

The dome control is based on a USB I/O controller, 2 relays, an Azimuth sensor and a Home position switch.
Usage of an USB I/O interface is the main advantage of this solution instead of Serial (RS232 COMx) or Parallel ports which are less and less available on new PCs.
Two optional relays are also used to power on/off the Telescope and a Camera.
It's also possible to control the dome shutter.

A discussion group has been open on Yahoo, if interested, join : http://groups.yahoo.com/group/lesvedome/

======================================

Created with the Personal Edition of HelpNDoc: Easily create EBooks


Distribution policy

Introduction ››

Shareware license

Previous Top Next

You must obtain a Registration Code to use this driver.

Without it, LesveDomeNet driver will inhibit any calls to Velleman K8055 module and you are not able to test your new system.

Trial Registration Code.

You can obtain for free a trial Registration Code, LesveDomeNet driver will be fully operational with this code for a period of 60 days.

See How to register

Permanent Registration Code

At or before trial period expiration, you must obtain a permanent Registration Code to continue to work with the LesveDomeNet driver.

To obtain a permanent Registration Code, you have to pay a license fee of 50 Euros (about 65 USD).

To pay this license fee use the following URL http://www.dppobservatory.net/Downloads/downloads.htm

Click on PayPal icon. You will be able to pay with Visa, MasterCard or PayPal.

As soon as I receive notification of the payment, I will send you the Permanent Registration Code.

If for any reason you switch to another PC, provide me the corresponding new Local Code and you will receive a new Registration Code.

Long term issues

In the long term, when LesveDomeNet driver will be obsolete and no more supported, I commit myself to release a last revision without registration key.

But it's still possible that something wrong happens to me!

To cope this issue, each time a new revision is released, a copy without registration key is deposited to my trustee friend Ken Menzies (kenmenstar at gmail.com)

In this worst case Ken has accepted to release it on the Yahoo LesveDomeNet group.

Created with the Personal Edition of HelpNDoc: Free PDF documentation generator


Registration

Created with the Personal Edition of HelpNDoc: Full-featured multi-format Help generator


How to register

Registration ››

How to register

Previous Top Next

Open the "Program Files\Common Files\ASCOM/Dome\ASCOM.LesveDomeNet", click ASCOM.LesveDomeNet.UserInterface.exe to open the LesveDomeNet program. Click successively on Setup and License Registration buttons.

If you open LesveDomeNet from another program (e.g. MaximDL or POTH ), in Setup Chooser window, select " LesveDomeNet Dome" click on Properties and License Registration buttons.

Send me an email ( pierredeponthiere@gmail.com ) to request a Registration Code.

Copy and Paste the Local Code generated for your computer in the email.

In return you will receive a trial Registration Code. Copy and Paste this code in the Registration Code box and click Register. Don't introduce blank characters at beginning or at the end of the code.

If for any reason you switch to another PC, provide me the corresponding Local Code and you will receive a new Registration Code.

Permanent Registration Code are provided if you have paid a license fee see Distribution policy

Created with the Personal Edition of HelpNDoc: Full-featured EPub generator


Installation

Created with the Personal Edition of HelpNDoc: Easily create iPhone documentation


LesveDome installation

Installation ››

LesveDome installation

Previous Top Next

As LesveDomeNet driver is ASCOM compliant, the ASCOM platform 6.1 SP1 or later (available as freeware http://ascom-standards.org/ ) must be installed before installing and running LesveDomeNet driver.

If you have troubles to install ASCOM Platform:

Visit Windows Update and make sure all of your software is up to date. In particular, make sure you have Microsoft .NET Framework 4.0 or later, it's free. Google for microsoft .net framework 4.0

Download the installation program : "ASCOM.LesveDomeNet 6.0.X.X Setup.exe" from the download page http://www.dppobservatory.net/Downloads/downloads.php

The LesveDomeNet driver and needed files will installed in the following directory:

C:\Program Files\Common Files\ASCOM\Dome\ASCOM.LesveDomeNet for Win XP

C:\Program Files (x86)\Common Files\ASCOM\Dome\ASCOM.LesveDomeNet for Win7

LesveDomeNet works with XP, Vista, Win7 and should work normally with Win8

Created with the Personal Edition of HelpNDoc: Full-featured Kindle eBooks generator


Hardware

Created with the Personal Edition of HelpNDoc: Easy EBook and documentation generator


Caution

Hardware ››

Caution

Previous Top Next

Caution

LesveDomeNet system is not a "Plug and Play" solution.

The system requires some wiring and assembly.

If you can understand some basic diagrams

and use a voltmeter then you would do fine.

This job does not require to be an expert in electronic and electrical engineering, a minimum knowledge is nevertheless required.

If you don't feel comfortable, try to find a friend to help you.

Don't hesitate to ask for support through the LesveDome Yahoo group:

http://groups.yahoo.com/group/lesvedome/

or with email to pierredeponthiere@gmail.com

In order to help you, please describe your configuration and try to be precise in your problem description.

Created with the Personal Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


USB IO Module

Hardware ››

Usb I/O Module

Previous Top Next

USB I/O Controller

The USB I/O controller is available as a low cost kit K8055N (the old model K8055 works also) (39 Euros in 2005) or as mounted module VM 110N from Velleman (a Belgian company www.velleman.eu ) but the product is also available from various resellers all over the world (see LesveDomeNet webpage).
Mounting this module is easy if you have a good soldering iron, Velleman documentation provides a step by step procedure to mount all the elements. With the module you receive also a test software to verify all the functions.

Specifications: http://www.velleman.eu/products/view/?id=404880

Created with the Personal Edition of HelpNDoc: Produce Kindle eBooks easily


Motor relays

Hardware ››

Motor relays

Previous Top Next

Two digital outputs are used to activate motor relays

ON/OFF relay

Clockwise/Counter Clockwise direction relay.

The position of the direction relay is also sensed with USB I/O, so if the dome is rotated with manual switches (see electrical diagrams Schematics ), the Ascom LesveDomeNet driver will be aware of this dome move.

Relay specifications

A lot of relays can be used, e.g. Velleman item VR10HD122C

http://www.velleman.be/es/en/product/view/?id=317946

Coil voltage 12VDC

Coil resistance 160 Ohm

Contacts: 2 x inverter (DPDT: Double Pole Double Through)

Contact rating 10A/24VDC or 220 VAC

The relays are plugged on Velleman SO8P sockets

The sockets are mounted on a 35 mm DIN rail, those rails are used in Europe for electric installation, here after a picture of circuit breakers mounted on a 35 mm DIN rail.

Shutter control (optional)

You will need 3 additional relays (same specifications)

Scope and Camera Power control (optional)

You will need 2 additional relays (same specifications)

Created with the Personal Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Technical Innovations Azimuth sensor

Hardware ››

Technical Innovations Azimuth sensor

Previous Top Next

Technical Innovations - Azimuth sensor

Azimuth sensor from Technical Innovations ( http://www.homedome.com ) is based on wheel in contact with the Dome base.

As the wheel is contact with the dome base, this wheel will rotate when the Dome is in move
You could also consider buying only the two Photo micro sensors from an electronic retailer and making yourself the mechanic instead to buy and adapt the Technical Innovation Azimuth sensor for your dome. Azimuth sensor is just an arm with a spring supporting the azimuth wheel and the photo sensors.
The two photo sensors, shown with yellow lines are Omron EE-SX1042, Google provides a lot of links for this component.

Specifications http://ecb.omron.com.sg/pdf/photomicrosensors/non-amplified/EE-SX1042.pdf

See also a DIY solution of Charles Harrow

Exploradome - Azimuth sensor

Exploradome users will have a look at the Charles Harrow files available at the Exploradome Yahoo group

https://groups.yahoo.com/neo/groups/Explora-dome/files/LESVEDOME%20/

See Chapter Exploradome solution

Created with the Personal Edition of HelpNDoc: Full-featured multi-format Help generator


DIY Azimuth sensor

Hardware ››

DIY Azimuth sensor

Previous Top Next

Rules for a DIY Azimuth sensor

If you want to design your own Azimuth sensor, you have to understand the operation

of the 2 bit Gray coder http://en.wikipedia.org/wiki/Gray_code . As you have seen in the section Technical Innovations Azimuth sensor , an azimuth sensor consists in a wheel with a number of holes and two photo-sensors.

Before to start your design, you have to define the number of holes for your azimuth sensor. All details are provided in sections Dome rotation speed issues and Timer value

As the dome rotates, successive holes are in front of both photo-sensors

The sequence is:

Photo-sensor#1 detects the beginning of hole #n

Photo-sensor#2 detects the beginning of hole #n

Photo-sensor#1 detects the end of hole #n

Photo-sensor#2 detects the end of hole #n

Photo-sensor#1 detects the beginning of hole #n+1

and so on..

To have these events equally timed, your azimuth wheel design and

photo-sensor location must be conform to :

N being the number of holes

spacing between holes = 360deg/N

size of holes = 360deg/(2*N) measured on the diameter on which the

photo-sensors will be

spacing of photo-sensors = 360deg/(4*N)

Nbr of holes | Hole spacing | Hole size | Photo-sensor spacing
2 | 180 | 90 | 45
4 | 90 | 45 | 22.5
6 | 60 | 30 | 15
8 | 45 | 22.5 | 11.25
12 | 30 | 15 | 7.5
24 | 15 | 7.5 | 3.75

You can see an example Exploradome design for a wheel with 24 holes.

DIY Azimuth sensor pictures

An 8 hole solution

An 10 hole solution

Javier Laina solution

A 2 hole solution, notice that opto-sensor spacing is 45 degrees

Created with the Personal Edition of HelpNDoc: Free EPub producer


Power supply issues

Hardware ››

Power supply issues

Previous Top Next

As some users got problems with Azimuth sensor power supply, I give hereafter a description of various power supply options.

- Full wave rectifier

A schematic of a full wave rectifier is given in next figure.

Have a look at http://www.allaboutcircuits.com/vol_3/chpt_3/4.html to understand how it works.

The AC voltage source is the output of transformer and not the 110VAC or 220VAC from main supply.

This kind of power supply is OK for motors and relays but not for power the Azimuth sensor.

The output voltage is always positive but drops 120 times per second in USA or 100 times per second in Europe, as you can see on the Oscilloscope connected to "Load".

If you supply Azimuth sensor with this kind of power supply, at each time the voltage drops the Azimuth sensor will generate a pulse and the Azimuth indication will be completely wrong.

Technical Innovation power supply is of this type, so do not use it directly for Azimuth sensor.

But behind the Full wave rectifier use a Regulated power supply as described in next paragraph.

- Regulated power supply

The LM341T-5.0 will regulate the output voltage of a full wave rectifier and generate a continuous 5 Volt output. Specifications http://cache.national.com/ds/LM/LM341.pdf

The Vin and Gnd are connected as the Load of the full wave rectifier.

I suggest to use for the capacitors beween Vin - Gnd and Vout - Gnd, capacitors of 10 microFarad rated for 25V. These capacitors are of electrolytic type and are polarity sensitive. Connect them correctly!! (+ to Vin and - to Gnd) and (+ to Vout and - to Gnd)

As the voltage output is 5VDC the resistor R1 (see schematic at next chapter) in series with Azimuth sensor will be 130 Ohm (instead of 560 Ohm for a 12VDC supply).

CAUTION: you cannot supply the relays with this regulated supply, indeed it does not provide the correct voltage and it is unable to provide enough current.

- Car battery

A 12V car battery can be used for powering : DC motors, relays and Azimuth sensor (with its series resistor R1). Do not forget to recharge it and take care of polarity when reconnecting it!

- Old PC power supply

I'm personally using an old PC power supply for the relays and Azimuth sensor.

PC power supply generates a regulated 12VDC voltage with a maximum of current of 10A.

This 10A current is not enough to supply the Technical Innovations motors, indeed when the motors start they generate a surge current well above 10A. At this time the PC power supply protection circuit becomes active and the output voltage drops.

For the motors I'm using the Full wave rectifier of Technical Innovations.

- Summary table of options

 | Motors | Relays | Azimuth sensor
TI full wave rectifier | OK | OK |
Regulator |  |  | OK
Car battery | OK | OK | OK
Old PC power supply |  | OK | OK

This table shows that you need 2 different options to supply motors, relays and Azimuth sensor. Except for the car battery option which is able to supply the 3 different loads.

Created with the Personal Edition of HelpNDoc: Free help authoring tool


Home sensor

Hardware ››

Home sensor

Previous Top Next

Reed relay for Home sensor

An example of a convenient Reed relay

http://www.velleman.be/es/en/product/view/?id=8055#

The relay must closed when the Home position is reached, i.e. when magnet is close to Reed relay.

Before installing it verify contact closure behavior in function of distance (do that with a Multimeter).

Created with the Personal Edition of HelpNDoc: Full-featured EBook editor


Schematics

Hardware ››

Schematics

Previous Top Next

General schematic

An electric schematic has been prepared by Charles Harrow.

Many thanks for his job.

Schematic of Charles Harrow

Schematic with ELK relays

Some users prefer to use Elk relays

Ed. Plumer has provided a schematic for the relay ELK 912 and 924,

see his picasaweb posting (picture101 of 110) https://picasaweb.google.com/eplumer/Observatory#

(1) ELK924 needs to be triggered in "insensitive" mode, (2) reverse-current protection diode D0 prevents the DI4 circuit from triggering ELK924 all the time. If Out2 is pulled to 0V, current can flow from In4 to Out2 and be detected by the 8055 as an input signal. However, If Out2 is not enable, the diode prevents current from exiting the 12V circuit of ELK input, into In4, through the pullup resistor, to the 5V level. (3) motor speed control board MX033 allows rotation speed to be lowered.

Single shutter schematic

Dennis Hohman has provided at following link interesting comments and schematic for shutter control.

http://tech.groups.yahoo.com/group/lesvedome/files/Dennis%20Hohman%27s%20Folder/

Dual shutter configuration schematic

Charles Harrow has designed an interesting schematic to operate dual shutter configuration.

In the Shutter control section you will find an explanation how it operates.

Dual Shutter configuration schematic

Please correct the following error in this schematic. It shows pin 5 as Up/Open and pin 6 as Down/Close, but it should show pin 5 as Shutter Motor On/Off and pin 6 as Shutter Open/Closed.

Dead man switch

Remote operation of an observatory has to handle failure issues.

Two of them are a failure of the PC controlling the observatory or a failure of the main electric supply. In those cases, it is interesting to have a system closing automatically the dome shutter and prevent damages in case of rain

The "Dead Man Switch" has been designed to cope those issues.

An external circuit named "Dead man switch" powered from a battery will detect if the LesveDomeNet driver is still active. LesveDomeNet driver is activating the Digital Output #8 regularly. If the "Dead Man Switch" is not reactivated from Digital Output #8, a dome shutter closure sequence is activated with the Velleman module K8015.

The schematic of Dead Man Switch is available here

This schematic has been carefully reviewed but to my knowledge it has not been already implemented.

Created with the Personal Edition of HelpNDoc: Easily create PDF Help documents


USB IO controller channel usage

Hardware ››

USB IO controller channel usage

Previous Top Next

LesveDomeNet controls a main board and also an optional second board.

At the software point of view LesveDomeNet provides two drivers, one "Dome" driver and one "Switch" driver.

The Dome driver groups all the need functions to control the dome.

The Switch driver groups all other functions like Turn On/Off the scope power supply, a dimmer and so on. ASCOM defines a Switch as follow:

"A switch device can be used to control something, such as a power switch or may be used to sense the state of something, such as a limit switch".

A switch may have more than the ON an OFF values, so a Slider is considered as a multi-states Switch. The main board controls the switches numbered 1 to 3 and the second board the switches 4 to 20.

Main board for dome control

Digital input channels
1 Azimuth Sensor “CCW motion”
2 Home position switch
3 Scope turned on bit
4 Dome Motor direction
5 Azimuth Sensor “CW motion”

Digital output channels
1 Dome Motor ON/OFF
2 Dome Motor direction CW CCW
3 Scope On - controlled by "Switch" driver as Switch #1
4 Scope Off - controlled by "Switch" driver as Switch #1
5 Shutter Motor ON/OFF
6 Shutter Open/Close. Open when relay is active
7 Ch#7 auxiliary relay - controlled by "Switch" driver as Switch #3
8 Dead Man Switch (see details here )

Analog inputs channels
1 Shutter limit switch option
2 Shutter limit switch option

Analog outputs channels
1 Dimmer for light controlled by "Switch" driver as Switch #2
2 not used

Second optional board for observatory switches and relay

Digital output channels
1 controlled by "Switch" driver as Switch #4
2 controlled by "Switch" driver as Switch #5
3 controlled by "Switch" driver as Switch #6
4 controlled by "Switch" driver as Switch #7
5 controlled by "Switch" driver as Switch #8
6 controlled by "Switch" driver as Switch #9
7 controlled by "Switch" driver as Switch #10
8 controlled by "Switch" driver as Switch #11

Digital input channels
1 controlled by "Switch" driver as Switch #12
2 controlled by "Switch" driver as Switch #13
3 controlled by "Switch" driver as Switch #14
4 controlled by "Switch" driver as Switch #15
5 controlled by "Switch" driver as Switch #16
Analog outputs channels
1 controlled by "Switch" driver as Switch #17
2 controlled by "Switch" driver as Switch #18
Analog inputs channels
1 controlled by "Switch" driver as Switch #19
2 controlled by "Switch" driver as Switch # 20

Created with the Personal Edition of HelpNDoc: iPhone web sites made easy


Shutter control

Hardware ››

Shutter control

Previous Top Next

A) Single shutter configuration

The shutter control software is designed to control a hardware similar to the Technical Innovations one http://www.homedome.com . The shutter motor is energized through two sliding contact plates. Electrical contacts supply shutter motor only when the dome is in Park/Home position.

So to open or close the shutter, the software will first move the dome to Park or Home position (as defined in Setup window).

The shutter move direction is selected by the polarity of voltage applied to contact plates. A special circuit comprising open and close magnetic sensors is located on the moving part of the dome. This circuit provides the mean to stop shutter motor when shutter is fully open or closed. Your schematic can be inspired from http://homedome.com/downloads/DDW4-install.zip , which contains a document "ddw4ins1.doc", a schematic is provided at page 84.

You can use the better and simpler solution provided by Denis Hohman (see Chapter Schematics ).

The software will assume that the shutter move is finished in a fixed time (this time is defined in the Setup window).
The dome move to Park or Home position for opening or closing the shutter is automatic. While the shutter is moving, dome azimuth control is disabled.
You have to specify an "Open/Close time" greater than the effective longer time taken by your shutter to open/close.

In the Setup window you can select position for shutter operation : Park, Home or Any position. Select appropriate position in respect of your dome configuration.

"Any position" is provided for configurations using radio link to send orders to rotating part of the dome, i.e. without sliding contacts.

B) Limit switch option

If you have Radio links between the dome rotating part and the dome base, you can use the Analog inputs to report to LesveDomeNet driver the real position of the shutter.

This option is easier to implement for a roll off roof as radio links are not needed.

Those Analog inputs will be used to read the status of the shutter:

Analog Input #1 at + 5V when shutter is fully open

Analog Input #2 at + 5V when shutter is fully closed

Both Analog Inputs are at 0V when shutter is moving

When an shutter opening or closing operation is started the following procedure is started

- shutter timer is started

- if a limit switch becomes active (+5V on analog input), the timer is stopped, the supply of motor is switched off and the shutter status is updated

- if timer expires before a limit switch is active, the shutter status

becomes "Error"

At LesveDomeNet turn on, the limit switches are read in order to determine the status of shutter.

In Setup window, check the box "Use Limit Switches" to use the Limit switch option.

CAUTION

The limit switches have to switch off the shutter motor, when to shutter move is complete.

Don't rely on software to switch off the shutter motor, you have to use the schematic provided Denis Hohman ( see previous section )

C) Dual shutter configuration

Some domes (Exploradome, Sirius,..) have upper and lower doors, which have to be open sequentially. For opening, the upper door will be open first and when this upper part is fully open the lower one will open. For closing, the lower will close first and upper afterwards.

This configuration has two motors, one for upper door and another for lower door.

For each door, 2 magnetic switches detect when the door is fully open and fully closed.

Charles Harrow has designed a circuit able to operate the dual shutter configuration.

It is an extension of the Denis Hohman design, so to understand how it operate it's suggested to understand first the one shutter configuration.

The following is a quick theory of operation for the dual door closing mechanism for the LesveDomeNet system.

Under the open command, Contacts J1-11 will be negative, J1-12 will be positive. The positive potential will flow through the normally closed contacts of SW3 energizing relay K7. The return path is through diode D19. K7 Provides power to motor M2 and insurers that no power will be available to M3. When the door has fully opened the magnet will have positioned itself such that it causes the contacts of SW3 to close and allows relay K7 and to de-energize. With the contact of SW3 now closed, power is fed to SW5 and energizes relay K8 through D21 and a return path through D22. The contact K8-A ensures that power will not be applied to the upper doors and the contacts of K8-B provides power to motor M3. Lastly when the lower door is fully open the magnet will cause SW5 to open, removing power to the motors. Note that diodes D17 and D20 do not provide a return path for any of the relays in this configuration.

When the close command is given, J1-11 we’ll be positive and J1-12 we’ll be negative. In this configuration switches SW3 and SW5 are effectively removed from the circuit due to steering diodes D16 and D21. The only path available for the positive potential from J1-11 is through the now closed contact of SW6 through diode D20 energizing relay K8 through a return path via D23. When the lower door is fully closed, the magnet will cause the contact of SW6 to open and provide power to SW4. Steering diode D17 causes relay K7 to energize through diode D18. When the upper door is fully closed, the magnet will cause the contact of SW4 to open removing power.

Created with the Personal Edition of HelpNDoc: Easily create EBooks


Human interfaces

Created with the Personal Edition of HelpNDoc: Full-featured multi-format Help generator


Dome Setup window

Human interfaces ››

Dome Dimensions

Dome diameter, when your system is working correctly, use the Estimate Dome Diameter in the main window. See Dome diameter

Azimuth Sensor Wheel Diameter

For Technical Innovations sensor enter 5.04 cm.

Azimuth Sensor Wheel - Hole number

For TI sensor enter 6.

Azimuth Control

Position Tolerance

Dome moves are stopped when dome position is in Tolerance. Don't use to small values otherwise you will have instable behavior. Typical value is 2 deg.

Park and Home Positions

Here you define the Park and Home positions.

Shutter Control

Open/Close time : choose a time longer than the time needed to open or close the shutter, see Shutter control

Operate anywhere can be useful if you have a radio control and a battery on the rotating part of the dome.

Check the box "Use Limit Switches" ONLY if you are using Limit switches for your shutter, See paragraph B in Shutter control

Interface Capabilities

Uncheck Find Home, Open/Close Shutter boxes if corresponding hardware is not installed.

Non Standard Behavior.

With AtHome without FindHome / AtPark without Park are checked, Home / Park indicators will be activated if dome is at corresponding azimuth even if it is not the result of an activation of Home or Park buttons.

Azimuth sensor mode and Time interval

see Dome rotation speed issues

K8055 address

has to be selected in accordance to jumpers SK5 and SK6 of your Velleman board.(0 to 3)

Created with the Personal Edition of HelpNDoc: Free EPub and documentation generator


Dome User Interface window

Human interfaces ››

Shutter indication: Open, Close, Opening, Closing or Error.

In case of Error, click Close.

Open, Stop and Close buttons for Shutter operations.

Dome

Azimuth dome position in degrees

Goto and Sync buttons allow to perform a Goto or to Synchronize the dome to specified Azimuth.

Step for CW or CCW, select the number of degrees the dome will move when CW or CCW button are clicked.

Clockwise and Counterclockwise buttons starts corresponding moves. Use the Stop button to stop.

Park and Home buttons allow to perform a move to Park and Home positions.

Connect / Disconnect.

Setup button opens the Setup window.

Registration see How to register

Created with the Personal Edition of HelpNDoc: Full-featured Kindle eBooks generator


Switch Setup window

Human interfaces ››

Use Main board

Check it if the Switch driver will use the switches of the main board

Use Second board

Check it if the Switch driver will use the switches of the second board

Main board address and Second board address

indicate the board addresses, be sure to avoid conflict with the address chosen in the Dome setup.

Switch number and Name

Here you may rename the switches for your convenience.

Created with the Personal Edition of HelpNDoc: Free HTML Help documentation generator


Switch User Interface window

Human interfaces ››

The switches 1 to 3 are pertaining to the main board, the other ones to the second board.

Only switches pertaining to a selected board are displayed when the the Switch driver is connected (Use the Connect / Disconnect button) see USB IO controller channel usage

This interface will be empty if the Switch driver is not connected.

Created with the Personal Edition of HelpNDoc: Easily create PDF Help documents


Parameter settings

Created with the Personal Edition of HelpNDoc: Write eBooks for the Kindle


Velleman K8055 module address

Parameter settings ››

Velleman K8055 module address

Previous Top Next

In Dome and Switch Setup windows, select the address of your Velleman board (0 to 3) in accordance with the jumpers SK5 and SK6

SK5 installed and SK6 installed address = 0
SK5 unstalled and SK6 installed address = 1
SK5 installed and SK6 unstalled address = 2
SK5 unstalled and SK6 unstalled address = 3

Created with the Personal Edition of HelpNDoc: Free help authoring tool


Dome rotation speed issues

Parameter settings ››

Dome rotation speed issues

Previous Top Next

The Ascom LesveDomeNet driver reads the state of the Azimuth sensor at regular time intervals “Interrupts” (thru USB I/O).
This time interval (or timer value) can be selected in the Setup window.
At each interrupt, the LesveDomeNet driver will call 2 to 4 times the USB I/O board in function of “Azimuth sensor mode”
This timer has to be short enough to be sure that you don't miss an Azimuth wheel transitions and not too short to let enough time to read/write the USB I/O module and let other programs to run.
The exact time USB controller takes to execute commands is not well defined. In original Velleman documentation, it is said that 20 msec is needed. After Velleman have released new version for the “dll” claiming a lower value but not specified. See also "Timer value" topic.

Three Azimuth sensor modes are supported.

1) Gray coder.

The Azimuth sensor comprises two photo sensors (glued together). In this mode, recommended if your dome is not rotating too quickly, we use both photo sensors to form a “Single-track Gray coder” (2-sensor, 1-track quadrature encoder). See this link for definition of Gray code http://en.wikipedia.org/wiki/Gray_code
In this mode, the LesveDomeNet driver has to read the Azimuth sensor at least four times during the move from the beginning of one hole and the beginning of the next one.
With Gray coder, the direction of move is detected directly from the Gray code. This has a major advantage. Indeed when you stop motors, after a short time the dome will stop but at the end of the stop process, due to elasticity of driving components, the dome will go for a short time in backward direction. With the Gray coder, the direction of this small move will be taken into account correctly.
In the other modes, this move is not correctly handled and generates small errors at each dome stops. When you are following the same star for a long period (time-series of 3 to 5 hours) the errors accumulate and the dome will be in late in respect to telescope.

The Gray coder uses both sensors and both have to be connected as follows (TI sensor):
Pin 2 (yellow wire) “Signal for CCW motion” is connected to Velleman K8055 Input I/O #1
Pin 3 (green wire) “Signal for CW motion” is connected to Velleman K8055 Input I/O #5
If the two signals are swapped the Azimuth reading will be in the wrong direction. If it’s the case, just swap the inputs #1 and #5.

2) Hole to Nohole transitions
In this mode, only one photo sensor is used (K8055 Input I/O #1), the LesveDomeNet driver detects holes and noholes. The LesveDomeNet driver has to read the Azimuth sensor at least two times during the move from the beginning of one hole and the beginning of the next one.
The dome position is less accurate (by a factor of 2) and the small backward moves when motor stops are not registered correctly.

3) Hole to hole transitions
In this mode, only one photo sensor is used (K8055 Input I/O #1), the hole transitions are registered with an internal counter of the Velleman module. LesveDomeNet driver reads this counter to know the dome azimuth. With this mode, you have no more real time constraints. But the dome position is less accurate (by a factor of 4 in respect to Gray code mode) and the small backward moves when motor stops are not registered correctly.

Created with the Personal Edition of HelpNDoc: Free PDF documentation generator


Timer value

Parameter settings ››

Timer value

Previous Top Next

An Excel file allows calculations of rotation speed parameters. Use this Excel file to determine which mode to use in your case.
In my application I've reduced the rotation speed (DC motors are now in series) to be sure to avoid problems. My dome is a Technical Innovation HD6S.
As said previously, Velleman does not specify the time to access the K8055 board. So experimentally I’ve seen that the system is still working with a timer value as low as 30 msec in the three modes. Recommended value would be 30 msec for recent PC's.

Experimentally I've discovered that the OS rounds the timer interrupt periods to a multiple of 16msec.
Conclusion : If possible adjust your dome rotation speed to be able to use the Gray code mode and you will have an accurate dome position reading and no accumulation of errors.
In your dome automation design, choose a 360 deg dome rotation time longer than 60 sec. My dome makes a full rotation in 130sec.

Created with the Personal Edition of HelpNDoc: Free Kindle producer


Frequently Asked Questions

Created with the Personal Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Telescope and dome synchronisation

Frequently Asked Questions ››

Telescope and dome synchronisation

Previous Top Next

ASCOM POTH is a software hub for telescope, dome and focuser which has a "Slave dome" function.

In Ascom POTH "Setup" you choose your telescope driver (LX200GPS, Celestron, ...) and LesveDomeNet driver as dome. You "Connect" both and as soon as you click on "Slave dome" check box in POTH main window, POTH will send regularly Azimuth move commands to LesveDomeNet driver.

The frequency and the accuracy of synchronization can be selected in POTH Setup.

Typical values are

5 sec for the synchronization period

2 degrees for the accuracy.

In your applications (MaximDL and others) you declare that your telescope is POTH.

Application programs

|

|

v

POTH

|

|

----------------------

| | |

v v v

Scope Dome Focuser

If you are using a German mount for your telescope, you have to define accurately the dome and telescope geometry in POTH Setup.

See also the ASCOM link http://ascom-standards.org/FAQs/POTH.htm

ACP

ACP (distributed by cd3.com) is a complete application to control all the items in your observatory

In this case, POTH is not needed, ACP will slave the LesveDomeNet to your telescope.

Created with the Personal Edition of HelpNDoc: Write EPub books for the iPad


Difference between Home and Park positions

Frequently Asked Questions ››

Difference between Home and Park positions

Previous Top Next

HOME => the position is detected by a magnetic switch. When this Home switch is closed, LesveDome resets its azimuth to defined value in Setup window.

PARK => preferred position to park the dome, can be any convenient position, also defined in Setup window.

To operate the shutter, the dome will move either to Home or Park positions, the shutter operating position is defined in Setup window.

Created with the Personal Edition of HelpNDoc: Full-featured Documentation generator


How to identify the Azimuth sensor pinning

Frequently Asked Questions ››

How to identify the Azimuth sensor pinning

Previous Top Next

Some users had difficulties to identify the pinning of Technical Innovations Azimuth Sensor.

This is probably due to cable type used between the Azimuth sensor and their electronic casing. Indeed some of telephony cables present a crossing in the wiring.

Hereafter a simple method to determine the pinning:

You need a Power supply of 12VDC, a 560 Ohm resistor (as usual to

limit current in Azimuth sensor), a Multimeter to measure the current

(available from RadioShark, an analog [$10] or digital [$30]).

The Azimuth sensor has 4 wires.

You have to connect two of them to the circuit at point 1 and 2, if

the current is zero you have not connected Anode and Cathode

correctly, try with other wires or try to invert the wires (12

possibilities!!).

ONLY ONE possibility will provide a reading around 20 mA.

At this time you have the pinning

Point 1 = AzimuthSensor Anode and Point 2 = Cathode (Ground).

The two other wires are CW and CCW.

With the resistor it's not possible to fry the Azimuth sensor.

When you have identified your pinning, install correctly your Azimuth

sensor and DON'T forget the resistor of 560 Ohm.

Link recommended for people not having a good electrical knowledge

See also http://www.allaboutcircuits.com/vol_3/chpt_3/2.html you will have a complete description of how to check a diode with a meter

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Azimuth sensor fails during sunny time

Frequently Asked Questions ››

Azimuth sensor fails during sunny time

Previous Top Next

It has been reported that if the Azimuth sensor is bathed with direct sun light, IR signal will be overwhelmed and sensor will not operate correctly. (See LesveDome Yahoo message 756).

To cope with this situation, you have to build a boot/shield to protect the wheel from direct and indirect light as much as possible. Something out of card board or painted flat material should do. Nothing fancy.

Created with the Personal Edition of HelpNDoc: Full-featured EPub generator


Exploradome solution of Charles Harrow

Created with the Personal Edition of HelpNDoc: Write EPub books for the iPad


Design overview

Exploradome solution of Charles Harrow ››

Design overview

Previous Top Next

If you have an Exploradome using the "Automation Track, Gear & Hardware" option, you will find here a description and the main needed parameters of an Azimuth sensor. Thanks to Charles Harrow who provided needed information.

The Azimuth sensor consists on a Commutator plate (with 24 holes) fixed mechanically to the Acorn Gear dragging the Track (attached to dome inside) . The Commutator plate holes are "read" by two photo sensors fixed on the small circuit board.

Created with the Personal Edition of HelpNDoc: Easily create EPub books


Photo sensors

Exploradome solution of Charles Harrow ››

Photo sensors

Previous Top Next

The Azimuth sensor is using two photo sensors to create a Gray coder.

The two photo sensors are Omron EE-SX1042, Google provides a lot of links for this component.

Specifications http://ecb.omron.com.sg/pdf/photomicrosensors/non-amplified/EE-SX1042.pdf

In the next picture (from specification document), dimensions are in millimeters.

In one branch of the photo sensor a LED is generating light, which is detected by the photo sensor located in the other branch, provided there is no obstruction.

Commutator will generate pulses at the output of the Omron photo sensor when the commutator is rotating. LesveDomeNet driver will read these pulses with the Digital Inputs of the Velleman module.

The two photo sensors are straddling the Commutator plate. The holes in Commutator plates are large enough to "see" both photo sensors at the same time.

From picture above, both photo sensors see the hole.

When the Commutator will start to rotate, one of the photo sensor A will see no more the hole and after a further rotation, photo sensors A and B will not see the hole.

While the rotation continues,

A will see the next hole

A and B will see this hole

B only will see this hole

A and B will not see this hole

a.s.o....

It's the way Gray coder is working.

Created with the Personal Edition of HelpNDoc: Free iPhone documentation generator


Detailed pictures

Exploradome solution of Charles Harrow ››

Detailed pictures

Previous Top Next

Detailed pictures of Charles Harrow design

The commutator’s drive shaft has a keyway 0.125 X 0.125 which is inserted into the commutator and acorn gear preventing unwanted independent rotation.

The length of the commutator shaft is determined by the degree of penetration of the motor shaft.

The shaft is retained with a ¼ x 20 screw and lock-washer which has been modified by removing a small section. The result is a key-way up to the screw.

Created with the Personal Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Motor

Exploradome solution of Charles Harrow ››

Motor

Previous Top Next

Charles Harrow has purchased his motor from www.surpluscenter.com .

The full address is:

http://www.surpluscenter.com/item.asp?UID=2008031707441487&item=5-1637&catname=electric

The current price is $59.95 us

Probably the most important thing is to mount the sensor to the motor base so that it follows the acorn gear’s movements.

The motor is listed as 7.5 RPM; however the name plate indicates that it is 1690 rpm with a 240:1 reduction. This indicates the RPM as 7.0417.

Theoretical rotation time is 170 / ( 7.0417 * 12) = 2.010 minutes

Created with the Personal Edition of HelpNDoc: Create iPhone web-based documentation


Commutator drawing

Exploradome solution of Charles Harrow ››

Commutator drawing

Previous Top Next

Created with the Personal Edition of HelpNDoc: Free help authoring environment


Parameters to enter in LesveDome Setup

Exploradome solution of Charles Harrow ››

Parameters to enter in LesveDomeNet Setup window

Previous Top Next

The TRACK fixed inside Exploradome has 170 holes.

The Acorn Gear has 12 teeth and a diameter of 6" (15.24 cm)

The effective diameter of Exploradome can be calculated as 6 * 170 / 12 = 85" (215.9 cm)

The Commutator plate has also a diameter of 6" and has 24 holes.

Introduce the following parameters in LesveDomeNet Setup window.

Dome diameter : 215.9

Azimuth Sensor Wheel diameter 15.24

Azimuth Sensor Wheel - Hole Number = 24

For a full dome rotation, 340 ticks will be generated by the Azimuth sensor

i.e. a tick every 353 msec.

With the Gray coder option the maximum interrupt time is 353 / 4 = 88msec.

Introduce a shorter value as 60 msec in Setup window.

Created with the Personal Edition of HelpNDoc: Easy EPub and documentation editor


Sirius domes

Created with the Personal Edition of HelpNDoc: Free EPub and documentation generator


Sirius domes

Sirius domes ››

Sirius domes

Previous Top Next

At this time, Huub (Netherlands) has successfully installed LesveDome with a Sirius dome.

He is using the original motor and manual control. A specific interface has been designed to be compatible with LesveDome.

A complete description is available at link http://www.dppobservatory.net/DomeAutomation/SiriusImplementation.pdf

Created with the Personal Edition of HelpNDoc: Easily create CHM Help documents


Miscellaneous

Created with the Personal Edition of HelpNDoc: iPhone web sites made easy


Velleman resellers

Miscellaneous ››

Velleman resellers

Previous Top Next

http://www.oceancontrols.com.au/data_acquisition/usb_8055.htm
http://www.ramseyelectronics.com/cgi-bin/commerce.exe?preadd=action&key=K8055
http://www.apogeekits.com/usb_interface.htm
http://www.jaycar.com.au/ keyword search "usb kit"
http://www.jaycar.co.nz/ keyword search "usb kit"
http://store.qkits.com/moreinfo.cfm/VM110
if you find other interesting reseller links, let me know I'll add your inputs.

Created with the Personal Edition of HelpNDoc: iPhone web sites made easy


Switch class

Miscellaneous ››

Switch class

Previous Top

ASCOM has defined an object SWITCH beside the Telescope, Dome, Focuser a.s.o.

LesveDomeNet driver implements a SWITCH class defined in ASCOM Platform V6.0.0.

For the detailed specification download the ASCOM PlatformDevelopment

http://ascom-standards.org/Downloads/PlatDevComponents.htm

The old swtich class defined in ASCOM Platform V 5 0 9 is no more supported by the new ASCOM platform V 6.0.0

The available switches are defined in Dome user interface window

From an external program it's possible to activate these switches.

If you want to experiment this feature, create the following script file (with Notepad) and save it as TestSwitch.vbs

TestSwitch.vbs

--------------------

driverID = "ASCOM.LesveDomeNet.Switch"

set o = CreateObject(driverID)

o.Connected = True

o.SetSwitch 3, True

MsgBox "click OK to end"

Click TestSwitch.vbs and the script will turn on the switch 3 i.e. the Digital Output #7 of the main board. This switch will be turned off automatically when leaving the script if no other application is connected to LesveDomeNet.Switch.

Created with the Personal Edition of HelpNDoc: Free Kindle producer